<!doctype html>
<html lang="en-US"
    xmlns:og="http://opengraphprotocol.org/schema/"
    xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-PH7GQKX');</script>
    <!-- End Google Tag Manager -->
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-83"></script>
    <script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-83');
    </script>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta http-equiv="X-UA-Compatible" content="ie=edge">
    <meta name="theme-color" content="#F0F0F0">
    <meta name="msapplication-TileColor" content=#F0F0F0>
    <meta property="og:locale" content="en_GB">
    <meta property="og:locale:alternate" content="en_US">
    <meta property="og:type" content="website" />
    <meta name="robots" content="index,follow">
    <meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
    <meta name="copyright" content="Nation Media Group">
    <link rel="manifest" href="https://nairobinews.nation.africa/manifest.json">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="mobile-web-app-capable" content="yes">
    <link rel="canonical" href="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/"/>
                        <link rel="amphtml" href="https://nairobinews.nation.africa/amp/article?slug=tom-mboyas-daughter-passes-on">
                   
    <link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-57x57.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-114x114.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-72x72.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-144x144.png" />
    <link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-60x60.png" />
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-120x120.png" />
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-76x76.png" />
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-152x152.png" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-196x196.png" sizes="196x196" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-96x96.png" sizes="96x96" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-32x32.png" sizes="32x32" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-16x16.png" sizes="16x16" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-128.png" sizes="128x128" />
    <meta name="application-name" content="&nbsp;"/>
    <meta name="msapplication-TileColor" content="#FFFFFF" />
    <meta name="msapplication-TileImage" content="mstile-144x144.png" />
    <meta name="msapplication-square70x70logo" content="mstile-70x70.png" />
    <meta name="msapplication-square150x150logo" content="mstile-150x150.png" />
    <meta name="msapplication-wide310x150logo" content="mstile-310x150.png" />
    <meta name="msapplication-square310x310logo" content="mstile-310x310.png" />
    <link rel="profile" href="https://gmpg.org/xfn/11">
    <style type="text/css">
@media only screen and (max-width: 990px) {
  #main-header {
    background: #ec1846;
    padding: 7px 0;
    position: fixed;
    top: 0;
    left: 0;
    right: 0;
    height: 50px;
    z-index: 999999;
    -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.1);
    box-shadow: 0 1px 2px rgba(0, 0, 0, 0.1);
    -webkit-backface-visibility: hidden;
    backface-visibility: hidden; }
    #main-header .ad-container {
      display: none; }
    #main-header .grid-4 {
      width: 100%; }
  .site-branding {
    max-width: 50px; }
  .hamburger-menu {
    position: absolute;
    right: 0;
    top: 0;
    -webkit-box-sizing: initial;
    box-sizing: initial;
    width: 22px;
    height: 20px;
    padding: 10px 22px;
    text-align: right;
    cursor: pointer;
    -webkit-user-select: none;
    -moz-user-select: none;
    -ms-user-select: none;
    user-select: none;
    border-radius: 0;
    background: transparent;
    border: none;
    -webkit-box-shadow: none;
    box-shadow: none; }
    .hamburger-menu .line-menu {
      display: inline-block;
      width: 22px;
      height: 2px;
      background: #fff;
      border-radius: 0;
      -webkit-transition: .2s;
      -o-transition: .2s;
      transition: .2s;
      display: block;
      position: relative;
      margin-right: auto;
      margin-top: 4px;
      -webkit-transition: all .4s;
      -o-transition: all .4s;
      transition: all .4s; }
      .hamburger-menu .line-menu:first-child {
        margin-top: 0; }
  .mobile-menu .site-logo {
    max-width: 50px; } 
}
        .main-nav {
            background: #ec1846;
            height: 50px;
            width: 100%;
        }
        .incontent-ad {
            float: left;
            width: 300px;
            padding: 0px;
            margin: 5px;
        }
    </style>
   
    <link rel="preload" href="https://nnmedia.nation.africa/assets/css/main_v0.css" as="style" onload="this.onload=null;this.rel='stylesheet'">
    <noscript>
        <link rel="stylesheet" href="https://nnmedia.nation.africa/assets/css/main_v0.css">
    </noscript>
    <title>Tom Mboya&#8217;s daughter passes on &#8211; Nairobi News</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//nnmedia.nation.africa' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.africa/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.africa/comments/feed/" />
 	<title>Tom Mboya&#8217;s daughter passes on</title>
    <meta property="og:title" content="Tom Mboya&#8217;s daughter passes on"/>
    <meta property="og:description" content='Rosemary Mboya, daughter of independence politician Tom Mboya, has passed on.

Ms Mboya passed on at a Nairobi hospital after battling breast cancer.

According to her sister Pamela Obonyo, the'/>
    <meta name="description" content='Rosemary Mboya, daughter of independence politician Tom Mboya, has passed on.

Ms Mboya passed on at a Nairobi hospital after battling breast cancer.

According to her sister Pamela Obonyo, the' />
    <meta name="keywords" content="Pamela Mboya, Tom Mboya    
    ">
    <meta property="fb:app_id" content="119242211439858" />
    <meta property="fb:pages" content="497615353664351"/>
    <meta property="og:locale" content="en_UK"/>
    <meta property="og:locale:alternate" content="en_US"/>
    <meta property="og:article:published_time" content="2022-12-15 17:02:59" />
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/"/>
    <meta property="og:site_name" content="Nairobi News"/>
    <meta property="og:image" content="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x740.jpg"/>
    <meta property="og:image:width" content="1400" />
	<meta property="og:image:height" content="744" />    
    <meta name="twitter:site" content="@Nairobi_News" />
    <meta name="twitter:title" content="Tom Mboya&#8217;s daughter passes on" />
    <meta property="article:publisher" content="https://www.facebook.com/NationNairobi/" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:description" content='Rosemary Mboya, daughter of independence politician Tom Mboya, has passed on.

Ms Mboya passed on at a Nairobi hospital after battling breast cancer.

According to her sister Pamela Obonyo, the' />
    <meta name="twitter:title" content="Tom Mboya&#8217;s daughter passes on" />
    <meta name="twitter:site" content="@Nairobi_News" />
    <meta name="twitter:image" content="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x740.jpg" />
    <meta name="twitter:creator" content="@Nairobi_News" />
    <script type="application/ld+json">
        {
        "@context": "https://schema.org/",
        "@type": "Article",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/"
        },
        "headline": "Tom Mboya&#8217;s daughter passes on",
        "description": "Rosemary Mboya, daughter of independence politician Tom Mboya, has passed on.

Ms Mboya passed on at a Nairobi hospital after battling breast cancer.

According to her sister Pamela Obonyo, the",
        "image": "https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x740.jpg",
        "author": {
            "@type": "Person",
            "name": "Mercy Simiyu"
        },
        "publisher": {
            "@type": "Organization",
            "name": "Nairobi News",
            "logo": {
            "@type": "ImageObject",
            "url": "https://nnmedia.nation.africa/assets/images/logo.svg"
            }
        },
        "datePublished": "2022-12-15T17:02:59+03:00",
        "dateModified": "2022-12-15T17:02:59+03:00"
        }
        </script>
 
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='_nn_clean-style-css'  href='https://nnmedia.nation.africa/assets/css/style.css' type='text/css' media='1' />
<link rel="https://api.w.org/" href="https://nairobinews.nation.africa/wp-json/" /><link rel="alternate" type="application/json" href="https://nairobinews.nation.africa/wp-json/wp/v2/posts/216235" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.africa/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.africa/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.3" />
<link rel="canonical" href="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/" />
<link rel='shortlink' href='https://nairobinews.nation.africa/?p=216235' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.africa/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.africa%2Ftom-mboyas-daughter-passes-on%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.africa/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.africa%2Ftom-mboyas-daughter-passes-on%2F&#038;format=xml" />
  
    <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
        googletag.defineSlot('/1010816/NN-728x90-1', [[970, 90], [320, 100], [728, 90]], 'div-gpt-ad-1649680740962-0').addService(googletag.pubads());
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
    });
    </script>
            <!--//everything else-->
       
       <!-- /1010816/NN-Profit-Button -->
        <script>
            window.googletag = window.googletag || {cmd: []};
            googletag.cmd.push(function() {
            googletag.defineOutOfPageSlot('/1010816/NN-Profit-Button', 'div-gpt-ad-1646634584003-0').addService(googletag.pubads());
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
        });

        </script>

        
    
 <script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/1010816/NN-Out-of-Page', 'div-gpt-ad-1656397419267-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
    
    <meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />

<script>
var pageConfig = {
    allowOverlayExpansion: true,
    allowPushExpansion: true,
    sandbox: true
};
googletag.pubads().setSafeFrameConfig(pageConfig);
</script>

<script>

  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-1x1', [1, 1], 'div-gpt-ad-1634797332515-0').addService(googletag.pubads());
	googletag.defineSlot('/1010816/NN-Arcticle-728x90', [[300, 250], [728, 90], [468, 60]], 'div-gpt-ad-1642148151895-0').addService(googletag.pubads());
	  googletag.defineSlot('/1010816/NN-Arcticle-728x90-2', [[728, 90], [300, 250], [468, 60]], 'div-gpt-ad-1642151579726-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });

</script>

<!-- Chartbeat_mab.js library is responsible for Chartbeat's headline and image testing functionality -->

<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>

</head>

<body class="inner-body">

<div id="sk-wrap">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PH7GQKX" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div id="content_overlay"></div>

<div id="mp-menu" class="mp-menu">
    <div class="mp-level">
        <div class="mp-level-scroll">
            <div class="search-form">
                <div class="form-container posRelative">
                    <!--<form action="https://nairobinews.nation.africa/" method="get">-->
                    <form action="https://nairobinews.nation.africa/results" method="get">
                        <input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
                        <button type="submit" class="search-submit" role="button"></button>
                    </form>
                </div>
            </div>
            <ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.africa/top-news/">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.africa/chillax/">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.africa/life/">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.africa/hustle/">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.africa/sports/">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.africa/blog/">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.africa/gallery/">Videos</a></li>
</ul>            <div class="whats-appLink">
                <div class="title">Join our Telegram Channel</div>
                <a href="https://telegram.me/NairobiNews">
                    <i class="fa fa-telegram"></i>
                    <span>Telegram</span>
                </a>
            </div>
            <div class="meta-social clearfix">
                <div class="social-content">
                    <ul class="unstyled">
                        <span class="title">Connect with us</span>
                        <li class="facebook">
                            <a href="https://www.facebook.com/NationNairobi" target="_blank" title="Facebook">
                                <i class="fa fa-facebook"></i>
                                <span class="hide">Facebook</span>
                            </a>
                        </li>
                        <li class="twitter">
                            <a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
                                <i class="fa fa-twitter"></i>
                                <span class="hide">Twitter</span>
                            </a>
                        </li>

                        <li class="instagram">
                            <a href="https://www.instagram.com/nationnairobi/" target="_blank" title="Instagram">
                                <i class="fa fa-instagram"></i>
                                <span class="hide">Instagram</span>
                            </a>
                        </li>
						
						<li class="tiktok">
                                    <a href="https://www.tiktok.com/@nairobi.news" target="_blank" title="TikTok">
                                        <i class="fa fa-tiktok"> <img src="https://nnmedia.nation.africa/assets/images/tiktok.svg" width="15px" height="15px"></i>
                                        <span class="hide">TikTok</span>
                                    </a>
                                </li>
                        <!-- <li id="alerts" class="alert close">
                            <a href="javascript:void(0);" title="Updates made in the last 5 minutes">
                                <span class="alert-num">
                                    1                                </span>
                                <i class="fa fa-bell"></i>
                                <span class="hide">Alerts</span>
                            </a>
                        </li> -->
                    </ul>
                </div>
            </div>
          
          
        </div>
    </div>
</div>
<div id="top-section">
    <header id="main-header" class="clearfix">
        <div class="row">
            <div class="row">
                <div class="grid-2 cell">
                    <div class="site-branding">
                        <h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
                        <div class="site-logo mobile-hidden">
                           <a href="https://nairobinews.nation.africa"><img src="https://nnmedia.nation.africa/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
                        </div>
                    </div>
                </div>
                                    <div class="grid-10 cell">
                        <div class="ad-container nobg">
                            
                                                	<div id="custom_html-35" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div>                                                </div>
                    </div>
               
			   
            </div>
        </div>
        <div id="mobile-menu" class="mobile-menu web-hidden">
            <div class="row">
                <div class="row">
                    <div class="grid-6 cell">
                        <div class="site-logo">
                            <a href="https://nairobinews.nation.africa">
                                <img src="https://nnmedia.nation.africa/assets/images/logo-black.svg" alt="Nairobi News Logo" />
                            </a>
                        </div>
                    </div>
                    <div class="grid-6 cell">
                        <div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
                            <div class="line-menu"></div>
                            <div class="line-menu"></div>
                            <div class="line-menu"></div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </header>
    <nav id="main-navigation" class="main-nav clearfix" role="nav">
        <div class="content">
            <div class="row">
                <div class="nav-left">
                    <ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.africa/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.africa/chillax/">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.africa/life/">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.africa/hustle/">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.africa/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.africa/blog/">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.africa/gallery/">Videos</a></li>
</ul>                </div>
                <div class="nav-right">
                    
                    <div id="search-show" class="right-search">
                        <div class="right-search__icon search-close">
                            <span class="fa fa-search"></span>
                        </div>
                        <div class="search-form">
                            <div class="form-container">
                                <form action="https://nairobinews.nation.africa/results" method="get">
                                    <input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
                                    <button type="submit" class="search-submit"></button>
                                </form>
                            </div>
                        </div>
                    </div>
                    <div class="meta-social clearfix">
                        <div class="social-content">
                            <ul class="unstyled">
                                <li class="facebook">
                                    <a href="https://www.facebook.com/NationNairobi" target="_blank" title="Facebook">
                                        <i class="fa fa-facebook"></i>
                                        <span class="hide">Facebook</span>
                                    </a>
                                </li>
                                <li class="twitter">
                                    <a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
                                        <i class="fa fa-twitter"></i>
                                        <span class="hide">Twitter</span>
                                    </a>
                                </li>

                                <li class="instagram">
                                    <a href="https://www.instagram.com/nationnairobi/" target="_blank" title="Instagram">
                                        <i class="fa fa-instagram"></i>
                                        <span class="hide">Instagram</span>
                                    </a>
                                </li>
								
								<li class="tiktok">
                                    <a href="https://www.tiktok.com/@nairobi.news" target="_blank" title="TikTok">
                                        <i class="fa fa-tiktok"> <img src="https://nnmedia.nation.africa/assets/images/tiktok.svg" width="15px" height="15px"></i>
                                        <span class="hide">TikTok</span>
                                    </a>
                                </li>
                                <li id="alerts" class="alert close">
                                    <a href="#" title="Updates made in the last 20 minutes">
                                        <span class="alert-num">
                                            1                                        </span>
                                        <i class="fa fa-bell"></i>
                                        <span class="hide">Alerts</span>
                                    </a>
                                </li>
                            </ul>
                        </div>
                    </div>
                    <div id="dropdown-latest" class="dropdown-item">
                        <div class="dropdown-content">
                            <!-- <div class="dropdown-title">
                                <h3>My alerts</h3>
                            </div> -->
                                                                                    <div class="item-list">
                                <a href="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/">Tom Mboya&#8217;s daughter passes on</a>
                                <span class="render-text">Updated 4 mins ago</span>
                            </div>
                            
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </nav>
</div>

<main id="main-content" role="content">

    
    <main id="main-content" role="article" class='main_content'>

        <section id="single-content" class="single-content mt-40 clearfix">
            <div class="content">
                <div class="row">
                    <div class="row">
                        <div class="grid-8 cell">
                            <div class="single-container">
								                                <div class="article-content">
                                    <div class="article-content__top">
                                        <div class="content-top__title">

                                            <span class="meta-label"><a href="https://nairobinews.nation.africa/category/editors-picks/">Must Read</a></span><span class="meta-label"><a href="https://nairobinews.nation.africa/category/news/">News</a></span>                                            <h2>Tom Mboya&#8217;s daughter passes on</h2>
                                        </div>
                                        <div class="content-top__meta mt-20 clearfix">
                                            <div class="row">
                                                <div class="grid-6 cell">
                                                    <div class="meta-articles__details">
                                                        <div class="meta-avatar">
                                                                                                                    <div class="avatar-content">
															    <div class="avatar-content__img wp-post-image" data-bg="url()"></div>
                                                            </div>
															
                                                                                                                </div>
                                                        <div class="meta-details">
                                                            <div class="meta-author">
                                                                                                                            <span class="render-text by">
                                                                    <span class="mr-5">By</span>
                                                                    <a href="javascript:void(0);" role="author">
																	Mercy Simiyu</a></span>
                                                             															 
                                                                <span>December 15th, 2022 <i class="dot"></i> 1 min read</span>
                                                            </div>
                                                        </div>
                                                    </div>
                                                </div>
                                                <div class="grid-6 cell">
                                                    <div class="meta-articles__social clearfix">
                                                        <div class="social-content">
                                                            <ul class="unstyled">
                                                                <li>
                                                                    <span>Share this</span>
                                                                </li>
                                                                <li class="facebook">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;t=Tom Mboya&#8217;s daughter passes on" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;t=Tom Mboya&#8217;s daughter passes on" title="Facebook">
                                                                        <i class="fa fa-facebook"></i>
                                                                        <span class="hide">Facebook</span>
                                                                    </a>
                                                                </li>
                                                                <li class="twitter">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://twitter.com/intent/tweet?url=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;text=Tom Mboya&#8217;s daughter passes on&via=Nairobi_News" title="Twitter">
                                                                        <i class="fa fa-twitter"></i>
                                                                        <span class="hide">Twitter</span>
                                                                    </a>
                                                                </li>

                                                                <li class="linkedin">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&title=Tom Mboya&#8217;s daughter passes on&summary=Tom Mboya&#8217;s daughter passes on&source=NairobiNews" title="LinkedIn">
                                                                        <i class="fa fa-linkedin"></i>
                                                                        <span class="hide">LinkedIn</span>
                                                                    </a>
                                                                </li>
                                                                <li class="email">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="mailto:?subject=Tom Mboya&#8217;s daughter passes on&body=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/" title="Email" target="_blank">
                                                                        <i class="fa fa-envelope-o"></i>
                                                                        <span class="hide">Email</span>
                                                                    </a>
                                                                </li>
                                                                <li class="whatsapp">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/" title="WhatsApp">
                                                                        <i class="fa fa-whatsapp"></i>
                                                                        <span class="hide">WhatsApp</span>
                                                                    </a>
                                                                </li>
                                                                
                                                                
                                                            </ul>
                                                        </div>
                                                    </div>
                                                </div>
                                            </div>
                                        </div>
                                    </div>
                                    <div class="article-content__banner">
                                        <div class="banner-container">
                                            <div class="banner-image">
                                               <img width="1320" height="729" src="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x729.jpg" class="attachment-single-image size-single-image wp-post-image" alt="" />                                                                                              <!-- <img width="auto" height="auto" src="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x729.jpg" loading="lazy" class="attachment-single-image size-single-image wp-post-image loaded" alt="Tom Mboya&#8217;s daughter passes on" data-src="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-1320x729.jpg" title="Tom Mboya&#8217;s daughter passes on" pinger-seen="true" data-was-processed="true" data-dw-processed-inimage="true" data-dw-target-viewable="true"> -->
                                            </div>
                                            <div class="banner-caption">
                                                <!--<span class="render-text"> Pamela Mboya, daughter of Independence politician Tom. PHOTO: COURTESY&nbsp;</span>-->
                                                <span class="render-text">Pamela Mboya, daughter of Independence politician Tom. PHOTO: COURTESY</span>                                            </div>
                                        </div>
                                    </div>
                                    <div class="article-content__content clearfix mt-40">
                                        
                                        <div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">
                                           <script>
											googletag.cmd.push(function() {
											googletag.defineSlot('/1010816/NN-ARTICLE-4', [300, 250], 'div-gpt-ad-1553666013837-0').addService(googletag.pubads());
											googletag.enableServices(); });
											</script>
											<div id='div-gpt-ad-1553666013837-0' style='height:250px; width:300px;'>
											<script>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553666013837-0'); });
											</script>
											</div>
                                            <br />
                                            
                                           
                                            
                                            
                                        </div>

                                        <p>Rosemary Mboya, daughter of independence politician Tom Mboya, has passed on.</p>
<p>Ms Mboya passed on at a Nairobi hospital after battling breast cancer.</p>
<p>According to her sister Pamela Obonyo, the deceased who bears a striking resemblance to her father was known for her generosity and for empowering the girl child in society.</p><div class='mobile-ad-'>
				<!--  /1010816/NN-Arcticle-728x90 -->
				<div id='div-gpt-ad-1642148151895-0'>
				<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1642148151895-0'); });
				</script>
				</div>
			</div>
<p>Obonyo described her fallen sister as a role model in society.</p>
<p>&#8220;I want my sister to be recognized as the daughter of a legend and a very good person in society,&#8221; said Ms Obonyo.</p>
<p>The family has appeared to Kenyans to help offset her medical bills with Ms Obonyo saying her sister&#8217;s treatment had drained her both emotionally, physically and financially.</p><div class='mobile-ad-'>
				<!-- /1010816/NN-Arcticle-728x90-2 -->
				<div id='div-gpt-ad-1642151579726-0'>
				<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1642151579726-0'); });
				</script>
				</div>

			</div>
<p>&#8220;She&#8217;s written many plays and was also in the Finance sector. She was a bank manager.&#8221;</p>
<p>Tom Mboya was a trade unionist, educator, Pan-Africanist, independence activist, and statesman.</p>
<p>He was one of Kenya&#8217;s founding fathers who led the negotiations for independence at the Lancaster House Conference.</p>
<p>He was also instrumental in forming Kenya&#8217;s independence party, the Kenya African National Union (KANU), where he served as its first secretary-general and became the country&#8217;s first Economic Planning and Development Ministry.</p>
<p>Tom Mboya was assassinated outside a pharmacy on Government Road (now Moi Avenue).</p>
<p>Up to this day, neither the real assassin nor the sponsors of it are known.</p>
<p>Also read: <a href="https://nairobinews.nation.africa/216228-2/">KANU suspends secretary Nick Salat</a></p>
<p><a href="https://nairobinews.nation.africa/kylian-mbappe-takes-center-stage-as-france-seeks-to-retain-world-cup-title/">Kylian Mbappé takes center stage as France seeks to retain World Cup title</a></p>
                                                                            </div>
                                    
                                                                          

                                    
    
    
                                    <div class="article-content__tags">

                                        <div class="list-tags">

                                            <ul  class="unstyled"><li><a href="https://nairobinews.nation.africa/tag/pamela-mboya/" rel="tag">Pamela Mboya</a></li><li><a href="https://nairobinews.nation.africa/tag/tom-mboya/" rel="tag">Tom Mboya</a></li></ul>
                                        </div>
                                        <div class="join-wc clearfix">
                                            <div class="row">
                                                <div class="grid-8 cell">
                                                    <div class="join-text">
                                                        <p>Nairobi News is now available on Telegram. For handpicked stories every day, subscribe to our channel today</p>
                                                    </div>
                                                </div>
                                                <div class="grid-4 cell">
                                                    <div class="join-link whats-appLink">
                                                        <a href="https://telegram.me/NairobiNews" target="_blank">
                                                            <i class="fa fa-commenting-o"></i>
                                                            <span>Telegram channel</span>
                                                        </a>
                                                    </div>
                                                </div>
                                            </div>
                                        </div>
                                    </div>
                                                                        <div id="stick-article-nav" class="article-content___nav">
                                        <div class="row">
                                            <div class="grid-4 cell">
                                                                                            <div class="content-nav__item prev-item">
                                                    <a href="https://nairobinews.nation.africa/216228-2/" title="KANU suspends secretary Nick Salat">
                                                        <span class="hide-mobile">
                                                            KANU suspends secretary Nick Salat                                                        </span>
                                                    </a>
                                                </div>
                                                                                        </div>
                                            <div class="grid-4 cell">
                                                <div class="meta-articles__social clearfix">
                                                    <div class="social-content">
                                                        <ul class="unstyled">
                                                            <li class="facebook">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;t=Tom Mboya&#8217;s daughter passes on" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;t=Tom Mboya&#8217;s daughter passes on" title="Facebook">
                                                                    <i class="fa fa-facebook"></i>
                                                                    <span class="hide">Facebook</span>
                                                                </a>
                                                            </li>
                                                            <li class="twitter">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://twitter.com/intent/tweet?url=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&amp;text=Tom Mboya&#8217;s daughter passes on&via=Nairobi_News" title="Twitter">
                                                                    <i class="fa fa-twitter"></i>
                                                                    <span class="hide">Twitter</span>
                                                                </a>
                                                            </li>

                                                            <li class="linkedin">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/&title=Tom Mboya&#8217;s daughter passes on&summary=Tom Mboya&#8217;s daughter passes on&source=NairobiNews" title="LinkedIn">
                                                                    <i class="fa fa-linkedin"></i>
                                                                    <span class="hide">LinkedIn</span>
                                                                </a>
                                                            </li>
                                                            <li class="email">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="mailto:?subject=Tom Mboya&#8217;s daughter passes on&body=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/" title="Email" target="_blank">
                                                                    <i class="fa fa-envelope-o"></i>
                                                                    <span class="hide">Email</span>
                                                                </a>
                                                            </li>
                                                            <li class="whatsapp">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/" title="WhatsApp">
                                                                    <i class="fa fa-whatsapp"></i>
                                                                    <span class="hide">WhatsApp</span>
                                                                </a>
                                                            </li>
                                                        </ul>
                                                    </div>
                                                </div>
                                            </div>
                                            <div class="grid-4 cell">
                                                                                        </div>
                                        </div>
                                    </div>
                                </div>
                                <div class="articles-content__author mt-40">
                                    <!-- start Chatbeat script-->
                                    <script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
                                    <script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/";
                                        _sf_async_config.title = "Tom Mboya’s daughter passes on";
                                        _sf_async_config.sections = "Must Read,News,";
                                        _sf_async_config.authors = "Mercy Simiyu";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>
                                    <!-- end Chatbeat script-->
                                    <!-- start content insights -->
                                    <script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "216235",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "Tom Mboya&#8217;s daughter passes on",
                                            pubdate: "2022-12-15",
											authors: "Mercy Simiyu",								
											sections: "Must Read,News,",
                                            tags: "Pamela Mboya, Tom Mboya, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>
                                    <!-- End content insights --> 
                                    <br />
                                                                    </div>
                                                                
                                
                            </div>
                        </div>
                        
                        <div class="grid-4 cell">
                            <div class="ad-container">
                                <div id="custom_html-27" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><div class='MainAdverTiseMentDiv' data-publisher="eyJpdiI6IkIxZHluU1RvZzZLWmZwUkRUODNJT3c9PSIsInZhbHVlIjoib2t1dDZWZGQxSHVnK2tTaWtkQ0U5dz09IiwibWFjIjoiNjUzZjdjMmYwYTY4YjE1ODUzNmY4MDk2MjFjZjA3NmQ4NzdmYmE1NzAxYjEyZjQ0NTRjOTFmOTc3NDU4NWE5MyJ9" data-adsize="300x250"></div> <script class="adScriptClass" src="https://ads.nation.africa/assets/ads/ad.js"></script></div></div>                                                                 
                                                            </div>
                            <div id="mustr-pane" class="vidoes-pane mt-20">
                                <div class="pane-grid pane-container clearfix">
                                    <div class="pane-title posRelative mb-20">
                                        <div class="pane-title__content">
                                            <div class="pane-title__heading">
                                                <h2>
                                                    <a href="https://nairobinews.nation.africa/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
                                                </h2>
                                            </div>
                                        </div>
                                    </div>
                                                                                                                <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/216228-2/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2020/02/Nick-Salat-1-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>KANU suspends secretary Nick Salat</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/kylian-mbappe-takes-center-stage-as-france-seeks-to-retain-world-cup-title/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/12/Kylian-Mbappe-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Kylian Mbappé takes center stage as France seeks to retain...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/watch-harmonize-eyes-eldoret-lady-amid-kajala-split/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2018/11/Harmonize-sing.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>WATCH: Harmonize eyes Eldoret lady amid Kajala split</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/more-pain-for-kenyans-as-power-tokens-prices-rise/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2018/04/KPLC-digital-meter.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>More pain for Kenyans as power tokens prices rise</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/anerlisa-muigai-throws-shade-at-side-chics-who-compete-with-goat-wives/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/12/Cover-photo-52-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Anerlisa Muigai throws shade at side chics who compete with...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/korgocho-mca-absalom-odhiambo-warns-odm-rebels-off-raila-odingas-family/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/12/MCA-11-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Korogocho MCA Absalom Odhiambo warns ODM rebels off Raila...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">December 15th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                    </div>
                            </div>
                            <div class="ad-container">
                                <div id="custom_html-28" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><div class='MainAdverTiseMentDiv' data-publisher="eyJpdiI6IkIxZHluU1RvZzZLWmZwUkRUODNJT3c9PSIsInZhbHVlIjoib2t1dDZWZGQxSHVnK2tTaWtkQ0U5dz09IiwibWFjIjoiNjUzZjdjMmYwYTY4YjE1ODUzNmY4MDk2MjFjZjA3NmQ4NzdmYmE1NzAxYjEyZjQ0NTRjOTFmOTc3NDU4NWE5MyJ9" data-adsize="300x250"></div> <script class="adScriptClass" src="https://ads.nation.africa/assets/ads/ad.js"></script></div></div>                            </div>                         
                            
                            <div id="buzz-pane" class="buzz-pane">
                                <div class="pane-grid pane-container clearfix">
                                    <div class="pane-title posRelative mb-20">
                                        <div class="pane-title__content">
                                            <div class="pane-title__heading">
                                                <h2>
                                                    <a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
                                                </h2>
                                            </div>
                                        </div>
                                    </div>
                                    
                                      <div class="pane-box">
                                        <a href="https://kenyabuzz.com/movies/preview/the-amazing-maurice" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1671092769.jfif)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>The Amazing Maurice</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p>Every town on Discworld knows the stories about rats and... </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>

                                    
                                      <div class="pane-box">
                                        <a href="https://kenyabuzz.com/movies/preview/avatar-the-way-of-water" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1670494539.jfif)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>Avatar 2: The Way of Water</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p> </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>

                                    
                                      <div class="pane-box">
                                        <a href="https://kenyabuzz.com/movies/preview/the-menu" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1669888990.jfif)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>The Menu</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p>A couple travels to a coastal island to eat at an exclusive... </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>

                                                                        
                                    

                                    
                                        <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/events/event/international-fashion-showcase" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://manage.kenyabuzz.com/public/uploads/posters/1670322572.jpeg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>International Fashion Showcase</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>Presented by Rangeela Bharat Welfare Society. </p>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>

                                    
                                        <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/events/event/bizarre-bazaar-christmas-festival-2022" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://manage.kenyabuzz.com/public/uploads/posters/1670419519.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Bizarre Bazaar: Christmas Festival 2022</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>This December Bizarre Bazaar Christmas Festival at Peponi... </p>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>

                                    
                                        <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/events/event/the-pink-dream" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://manage.kenyabuzz.com/public/uploads/posters/1670323070.jpeg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>The Pink Dream</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>A Ballet Production </p>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>

                                                                        
                                    
                                                                            <!-- <div class="pane-box">
                                            <a href="https://cms.kenyabuzz.com/lifestyle/" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url()"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3></h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p> </p>
                                                    </div>
                                                    
                                                </div>
                                            </a>
                                        </div> -->
                                                                       
                                </div>
                            </div>
                            
                            <div id="taboola-ads" class="taboola-ad-below-article content-sticky">
                                    <!-- start revenue script-->
                                    <div id="taboola-below-article-thumbnails"></div>
                                    <script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>
                                    <!-- end revenue script-->
                                </div>
                                
                        </div>
                     
                        
                    </div>
                </div>
            </div>
            <div class="smart_scroll_container" id='post-216179'></div>
        </section>
    </main>


<footer id="main-footer" class="mt-40" role="section">
    <div class="top-footer padt40 padb40 clearfix">
        <div class="content">
            <div class="row">
                <div class="row">
                    <div class="grid-4 cell">
                        <div class="top-footer__about">
                            <div class="about-logo__img">
                                <img src="https://nnmedia.nation.africa/assets/images/logo-footer.png" alt="Nairobi News Logo" />
                            </div>
                                                        
                            								                                    <!-- /1010816/NN-Profit-Button body-->
                                       <div id='div-gpt-ad-1646634584003-0'>
                                            <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646634584003-0'); });</script>
                                        </div>
                                    
                                                            
                                                        <!-- /1010816/NN-Home-300x250-1 -->
                           
                        </div>
                    </div>
                    <div class="grid-4 cell">
                        <div class="pane-grid pane-container clearfix">
                            <div class="pane-title posRelative mb-20">
                                <div class="pane-title__content">
                                    <div class="pane-title__heading">
                                        <h2>
                                           Most Popular
                                        </h2>
                                    </div>
                                </div>
                            </div>
                                                                                    <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/ladies-quit-playing-wife-ring/"><img width="109" height="73" src="https://nnmedia.nation.africa/uploads/2018/04/Ring.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="FILE PHOTO" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/ladies-quit-playing-wife-ring/">BLOG: Ladies, quit &#8216;playing wife’ if he hasn&#8217;t put a ring on it</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 8th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                                                        <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/drama-as-kajala-and-harmonize-fight-over-car-ownership/"><img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/12/Cover-photo-2022-12-13T101126.485-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Ex-couple Fridah Kajala and Harmonize" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/drama-as-kajala-and-harmonize-fight-over-car-ownership/">Drama as Kajala and Harmonize fight over car ownership</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 13th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                                                        <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/tiktok-star-mummie-francie-critics-charlene-rutos-wigs-and-dressing/"><img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/12/Cover-photo-2022-12-14T112547.329-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Charlene Ruto and Mummie Francie" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/tiktok-star-mummie-francie-critics-charlene-rutos-wigs-and-dressing/">Tiktok star Mummie Francie critiques Charlene Ruto&#8217;s wigs and dressing</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 14th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                            
                        </div>
                    </div>
                    <div class="grid-4 cell">
                        <div class="pane-grid pane-container clearfix">
                            <div class="pane-title posRelative mb-20">
                                <div class="pane-title__content">
                                    <div class="pane-title__heading">
                                        <h2>
                                           Don't Miss
                                        </h2>
                                    </div>
                                </div>
                            </div>
                                                                                    <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/12/Tom-Mboya-11-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/tom-mboyas-daughter-passes-on/">Tom Mboya&#8217;s daughter passes on</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 15th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                                                        <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/216228-2/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2020/02/Nick-Salat-1-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/216228-2/">KANU suspends secretary Nick Salat</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 15th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                                                        <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/kylian-mbappe-takes-center-stage-as-france-seeks-to-retain-world-cup-title/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/12/Kylian-Mbappe-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/kylian-mbappe-takes-center-stage-as-france-seeks-to-retain-world-cup-title/">Kylian Mbappé takes center stage as France seeks to retain World Cup title</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">December 15th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                            
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="bottom-footer text-center padt20 padb20">
            <span class="render-text">
                Copyright &copy; 2022 Nation Media Group. All rights reserved.
            </span>
    </div>

</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<script src="https://nnmedia.nation.africa/assets/js/plugins.js"></script>
<script src="https://nnmedia.nation.africa/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>	
    <script type="text/javascript" async>
        window._taboola = window._taboola || [];
        _taboola.push({article:'auto'});
        !function (e, f, u, i) {
            if (!document.getElementById(i)){
                e.async = 1;
                e.src = u;
                e.id = i;
                f.parentNode.insertBefore(e, f);
            }
        }(document.createElement('script'),
            document.getElementsByTagName('script')[0],
            '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
            'tb_loader_script');
    </script>
<script type="text/javascript" async>
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript" async>
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#!'+id;
          window.history.pushState({path:newurl},'',newurl);
		  //alert(id);
      }
    }
</script>

<script type='text/javascript'>
    (function() {
        /** CONFIGURATION START **/
        var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
        _sf_async_config.uid = 63208; //CHANGE THIS TO YOUR ACCOUNT ID
        _sf_async_config.domain = 'nairobinews.nation.africa'; //CHANGE THIS TO YOUR SITE ID
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = true;
        _sf_async_config.sections = ''; //SET PAGE SECTION(S)
        _sf_async_config.authors = ''; //SET PAGE AUTHOR(S)
        /** CONFIGURATION END **/
        function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat.js';
            n.parentNode.insertBefore(e, n);
        }
        loadChartbeat();
     })();
    </script>
<!-- /1010816/NN-Out-of-Page -->
<div id='div-gpt-ad-1656397419267-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1656397419267-0'); });
  </script>
</div>
<!-- /1010816/NN-1x1 -->
<div id="gpt-passback">
  <script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-1x1', [1, 1], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
<div id='div-gpt-ad-1632916589183-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1632916589183-0'); });
  </script>
</div>
<!-- Google Tag Manager (noscript) -->
</div>
<script>window.tentacles = {apiToken: 'w2vn6fbas3t2q3zf5vtz9vx6md2exan5'};</script>
<script async src="https://tentacles.smartocto.com/ten/tentacle.js"></script>
</body>
</html>