<!doctype html>
<html lang="en-US"
    xmlns:og="http://opengraphprotocol.org/schema/"
    xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-PH7GQKX');</script>
    <!-- End Google Tag Manager -->
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-83"></script>
    <script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-83');
    </script>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta http-equiv="X-UA-Compatible" content="ie=edge">
    <meta name="theme-color" content="#F0F0F0">
    <meta name="msapplication-TileColor" content=#F0F0F0>
    <meta property="og:locale" content="en_GB">
    <meta property="og:locale:alternate" content="en_US">
    <meta property="og:type" content="website" />
    <meta name="robots" content="index,follow">
    <meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
    <meta name="copyright" content="Nation Media Group">
    <link rel="manifest" href="https://nairobinews.nation.africa/manifest.json">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="mobile-web-app-capable" content="yes">
    <link rel="canonical" href="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/"/>
                        <link rel="amphtml" href="https://nairobinews.nation.africa/amp/article?slug=hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru">
                   
    <link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-57x57.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-114x114.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-72x72.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-144x144.png" />
    <link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-60x60.png" />
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-120x120.png" />
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-76x76.png" />
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://nnmedia.nation.africa/assets/images/favicon/apple-touch-icon-152x152.png" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-196x196.png" sizes="196x196" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-96x96.png" sizes="96x96" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-32x32.png" sizes="32x32" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-16x16.png" sizes="16x16" />
    <link rel="icon" type="image/png" href="https://nnmedia.nation.africa/assets/images/favicon/favicon-128.png" sizes="128x128" />
    <meta name="application-name" content="&nbsp;"/>
    <meta name="msapplication-TileColor" content="#FFFFFF" />
    <meta name="msapplication-TileImage" content="mstile-144x144.png" />
    <meta name="msapplication-square70x70logo" content="mstile-70x70.png" />
    <meta name="msapplication-square150x150logo" content="mstile-150x150.png" />
    <meta name="msapplication-wide310x150logo" content="mstile-310x150.png" />
    <meta name="msapplication-square310x310logo" content="mstile-310x310.png" />
    <link rel="profile" href="https://gmpg.org/xfn/11">
    <style type="text/css">
@media only screen and (max-width: 990px) {
  #main-header {
    background: #ec1846;
    padding: 7px 0;
    position: fixed;
    top: 0;
    left: 0;
    right: 0;
    height: 50px;
    z-index: 999999;
    -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.1);
    box-shadow: 0 1px 2px rgba(0, 0, 0, 0.1);
    -webkit-backface-visibility: hidden;
    backface-visibility: hidden; }
    #main-header .ad-container {
      display: none; }
    #main-header .grid-4 {
      width: 100%; }
  .site-branding {
    max-width: 50px; }
  .hamburger-menu {
    position: absolute;
    right: 0;
    top: 0;
    -webkit-box-sizing: initial;
    box-sizing: initial;
    width: 22px;
    height: 20px;
    padding: 10px 22px;
    text-align: right;
    cursor: pointer;
    -webkit-user-select: none;
    -moz-user-select: none;
    -ms-user-select: none;
    user-select: none;
    border-radius: 0;
    background: transparent;
    border: none;
    -webkit-box-shadow: none;
    box-shadow: none; }
    .hamburger-menu .line-menu {
      display: inline-block;
      width: 22px;
      height: 2px;
      background: #fff;
      border-radius: 0;
      -webkit-transition: .2s;
      -o-transition: .2s;
      transition: .2s;
      display: block;
      position: relative;
      margin-right: auto;
      margin-top: 4px;
      -webkit-transition: all .4s;
      -o-transition: all .4s;
      transition: all .4s; }
      .hamburger-menu .line-menu:first-child {
        margin-top: 0; }
  .mobile-menu .site-logo {
    max-width: 50px; } 
}
        .main-nav {
            background: #ec1846;
            height: 50px;
            width: 100%;
        }
        .incontent-ad {
            float: left;
            width: 300px;
            padding: 0px;
            margin: 5px;
        }
    </style>
   
    <link rel="preload" href="https://nnmedia.nation.africa/assets/css/main_v0.css" as="style" onload="this.onload=null;this.rel='stylesheet'">
    <noscript>
        <link rel="stylesheet" href="https://nnmedia.nation.africa/assets/css/main_v0.css">
    </noscript>
    <title>Hope you will not stop coming to my races, Omanyala tells Uhuru &#8211; Nairobi News</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//nnmedia.nation.africa' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.africa/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.africa/comments/feed/" />
 	<title>Hope you will not stop coming to my races, Omanyala tells Uhuru</title>
    <meta property="og:title" content="Hope you will not stop coming to my races, Omanyala tells Uhuru"/>
    <meta property="og:description" content='Africa's fastest man Ferdinand Omanyala has thanked retired President Uhuru Kenyatta for his service even in the sporting arena.

In a post shared across his social media platforms, Omanyala'/>
    <meta name="description" content='Africa's fastest man Ferdinand Omanyala has thanked retired President Uhuru Kenyatta for his service even in the sporting arena.

In a post shared across his social media platforms, Omanyala' />
    <meta name="keywords" content="Africa's fastest man, Ferdinand Omanyala, Kasarani Stadium, Kip Keino Classic, President Uhuru Kenyatta    
    ">
    <meta property="fb:app_id" content="119242211439858" />
    <meta property="fb:pages" content="497615353664351"/>
    <meta property="og:locale" content="en_UK"/>
    <meta property="og:locale:alternate" content="en_US"/>
    <meta property="og:article:published_time" content="2022-09-14 11:42:52" />
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/"/>
    <meta property="og:site_name" content="Nairobi News"/>
    <meta property="og:image" content="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3-1320x740.jpg"/>
    <meta property="og:image:width" content="1400" />
	<meta property="og:image:height" content="744" />    
    <meta name="twitter:site" content="@Nairobi_News" />
    <meta name="twitter:title" content="Hope you will not stop coming to my races, Omanyala tells Uhuru" />
    <meta property="article:publisher" content="https://www.facebook.com/NationNairobi/" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:description" content='Africa\'s fastest man Ferdinand Omanyala has thanked retired President Uhuru Kenyatta for his service even in the sporting arena.

In a post shared across his social media platforms, Omanyala' />
    <meta name="twitter:title" content="Hope you will not stop coming to my races, Omanyala tells Uhuru" />
    <meta name="twitter:site" content="@Nairobi_News" />
    <meta name="twitter:image" content="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3-1320x740.jpg" />
    <meta name="twitter:creator" content="@Nairobi_News" />
    <script type="application/ld+json">
        {
        "@context": "https://schema.org/",
        "@type": "Article",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/"
        },
        "headline": "Hope you will not stop coming to my races, Omanyala tells Uhuru",
        "description": "Africa\'s fastest man Ferdinand Omanyala has thanked retired President Uhuru Kenyatta for his service even in the sporting arena.

In a post shared across his social media platforms, Omanyala",
        "image": "https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3-1320x740.jpg",
        "author": {
            "@type": "Person",
            "name": "Wangu Kanuri"
        },
        "publisher": {
            "@type": "Organization",
            "name": "Nairobi News",
            "logo": {
            "@type": "ImageObject",
            "url": "https://nnmedia.nation.africa/assets/images/logo.svg"
            }
        },
        "datePublished": "2022-09-14T11:42:52+03:00",
        "dateModified": "2022-09-14T11:42:52+03:00"
        }
        </script>
 
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='_nn_clean-style-css'  href='https://nnmedia.nation.africa/assets/css/style.css' type='text/css' media='1' />
<link rel="https://api.w.org/" href="https://nairobinews.nation.africa/wp-json/" /><link rel="alternate" type="application/json" href="https://nairobinews.nation.africa/wp-json/wp/v2/posts/201428" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.africa/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.africa/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.2" />
<link rel="canonical" href="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/" />
<link rel='shortlink' href='https://nairobinews.nation.africa/?p=201428' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.africa/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.africa%2Fhope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.africa/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.africa%2Fhope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru%2F&#038;format=xml" />
  
    <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
        googletag.defineSlot('/1010816/NN-728x90-1', [[970, 90], [320, 100], [728, 90]], 'div-gpt-ad-1649680740962-0').addService(googletag.pubads());
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
    });
    </script>
            <!--//everything else-->
       
       <!-- /1010816/NN-Profit-Button -->
        <script>
            window.googletag = window.googletag || {cmd: []};
            googletag.cmd.push(function() {
            googletag.defineOutOfPageSlot('/1010816/NN-Profit-Button', 'div-gpt-ad-1646634584003-0').addService(googletag.pubads());
            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
        });

        </script>

        
    
 <script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/1010816/NN-Out-of-Page', 'div-gpt-ad-1656397419267-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
    
    <meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />

<script>
var pageConfig = {
    allowOverlayExpansion: true,
    allowPushExpansion: true,
    sandbox: true
};
googletag.pubads().setSafeFrameConfig(pageConfig);
</script>

<script>

  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-1x1', [1, 1], 'div-gpt-ad-1634797332515-0').addService(googletag.pubads());
	googletag.defineSlot('/1010816/NN-Arcticle-728x90', [[300, 250], [728, 90], [468, 60]], 'div-gpt-ad-1642148151895-0').addService(googletag.pubads());
	  googletag.defineSlot('/1010816/NN-Arcticle-728x90-2', [[728, 90], [300, 250], [468, 60]], 'div-gpt-ad-1642151579726-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });

</script>

</head>

<body class="inner-body">

<div id="sk-wrap">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PH7GQKX" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div id="content_overlay"></div>

<div id="mp-menu" class="mp-menu">
    <div class="mp-level">
        <div class="mp-level-scroll">
            <div class="search-form">
                <div class="form-container posRelative">
                    <!--<form action="https://nairobinews.nation.africa/" method="get">-->
                    <form action="https://nairobinews.nation.africa/results" method="get">
                        <input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
                        <button type="submit" class="search-submit" role="button"></button>
                    </form>
                </div>
            </div>
            <ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.africa/top-news/">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.africa/chillax/">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.africa/life/">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.africa/hustle/">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.africa/sports/">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.africa/blog/">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.africa/gallery/">Gallery</a></li>
</ul>            <div class="whats-appLink">
                <div class="title">Join our Telegram Channel</div>
                <a href="https://telegram.me/NairobiNews">
                    <i class="fa fa-telegram"></i>
                    <span>Telegram</span>
                </a>
            </div>
            <div class="meta-social clearfix">
                <div class="social-content">
                    <ul class="unstyled">
                        <span class="title">Connect with us</span>
                        <li class="facebook">
                            <a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
                                <i class="fa fa-facebook"></i>
                                <span class="hide">Facebook</span>
                            </a>
                        </li>
                        <li class="twitter">
                            <a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
                                <i class="fa fa-twitter"></i>
                                <span class="hide">Twitter</span>
                            </a>
                        </li>

                        <li class="instagram">
                            <a href="http://instagram.com/Nairobi_News" target="_blank" title="Instagram">
                                <i class="fa fa-instagram"></i>
                                <span class="hide">Instagram</span>
                            </a>
                        </li>
                        <!-- <li id="alerts" class="alert close">
                            <a href="javascript:void(0);" title="Updates made in the last 5 minutes">
                                <span class="alert-num">
                                    0                                </span>
                                <i class="fa fa-bell"></i>
                                <span class="hide">Alerts</span>
                            </a>
                        </li> -->
                    </ul>
                </div>
            </div>
          
          
        </div>
    </div>
</div>
<div id="top-section">
    <header id="main-header" class="clearfix">
        <div class="row">
            <div class="row">
                <div class="grid-2 cell">
                    <div class="site-branding">
                        <h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
                        <div class="site-logo mobile-hidden">
                           <a href="https://nairobinews.nation.africa"><img src="https://nnmedia.nation.africa/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
                        </div>
                    </div>
                </div>
                                    <div class="grid-10 cell">
                        <div class="ad-container nobg">
                            
                                                	<div id="custom_html-35" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div>                                                </div>
                    </div>
               
			   
            </div>
        </div>
        <div id="mobile-menu" class="mobile-menu web-hidden">
            <div class="row">
                <div class="row">
                    <div class="grid-6 cell">
                        <div class="site-logo">
                            <a href="https://nairobinews.nation.africa">
                                <img src="https://nnmedia.nation.africa/assets/images/logo-black.svg" alt="Nairobi News Logo" />
                            </a>
                        </div>
                    </div>
                    <div class="grid-6 cell">
                        <div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
                            <div class="line-menu"></div>
                            <div class="line-menu"></div>
                            <div class="line-menu"></div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </header>
    <nav id="main-navigation" class="main-nav clearfix" role="nav">
        <div class="content">
            <div class="row">
                <div class="nav-left">
                    <ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.africa/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.africa/chillax/">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.africa/life/">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.africa/hustle/">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.africa/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.africa/blog/">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.africa/gallery/">Gallery</a></li>
</ul>                </div>
                <div class="nav-right">
                    
                    <div id="search-show" class="right-search">
                        <div class="right-search__icon search-close">
                            <span class="fa fa-search"></span>
                        </div>
                        <div class="search-form">
                            <div class="form-container">
                                <form action="https://nairobinews.nation.africa/results" method="get">
                                    <input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
                                    <button type="submit" class="search-submit"></button>
                                </form>
                            </div>
                        </div>
                    </div>
                    <div class="meta-social clearfix">
                        <div class="social-content">
                            <ul class="unstyled">
                                <li class="facebook">
                                    <a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
                                        <i class="fa fa-facebook"></i>
                                        <span class="hide">Facebook</span>
                                    </a>
                                </li>
                                <li class="twitter">
                                    <a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
                                        <i class="fa fa-twitter"></i>
                                        <span class="hide">Twitter</span>
                                    </a>
                                </li>

                                <li class="instagram">
                                    <a href="http://instagram.com/Nairobi_News" target="_blank" title="Instagram">
                                        <i class="fa fa-instagram"></i>
                                        <span class="hide">Instagram</span>
                                    </a>
                                </li>
                                <li id="alerts" class="alert close">
                                    <a href="#" title="Updates made in the last 20 minutes">
                                        <span class="alert-num">
                                            1                                        </span>
                                        <i class="fa fa-bell"></i>
                                        <span class="hide">Alerts</span>
                                    </a>
                                </li>
                            </ul>
                        </div>
                    </div>
                    <div id="dropdown-latest" class="dropdown-item">
                        <div class="dropdown-content">
                            <!-- <div class="dropdown-title">
                                <h3>My alerts</h3>
                            </div> -->
                                                                                    <div class="item-list">
                                <a href="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/">Hope you will not stop coming to my races, Omanyala tells Uhuru</a>
                                <span class="render-text">Updated 9 mins ago</span>
                            </div>
                            
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </nav>
</div>

<main id="main-content" role="content">

    
    <main id="main-content" role="article" class='main_content'>

        <section id="single-content" class="single-content mt-40 clearfix">
            <div class="content">
                <div class="row">
                    <div class="row">
                        <div class="grid-8 cell">
                            <div class="single-container">
								                                <div class="article-content">
                                    <div class="article-content__top">
                                        <div class="content-top__title">

                                            <span class="meta-label"><a href="https://nairobinews.nation.africa/category/sports/">Sports</a></span><span class="meta-label"><a href="https://nairobinews.nation.africa/category/featured/">What's Hot</a></span>                                            <h2>Hope you will not stop coming to my races, Omanyala tells Uhuru</h2>
                                        </div>
                                        <div class="content-top__meta mt-20 clearfix">
                                            <div class="row">
                                                <div class="grid-6 cell">
                                                    <div class="meta-articles__details">
                                                        <div class="meta-avatar">
                                                                                                                    <div class="avatar-content">
															    <div class="avatar-content__img wp-post-image" data-bg="url()"></div>
                                                            </div>
															
                                                                                                                </div>
                                                        <div class="meta-details">
                                                            <div class="meta-author">
                                                                                                                            <span class="render-text by">
                                                                    <span class="mr-5">By</span>
                                                                    <a href="javascript:void(0);" role="author">
																	Wangu Kanuri</a></span>
                                                             															 
                                                                <span>September 14th, 2022 <i class="dot"></i> 2 min read</span>
                                                            </div>
                                                        </div>
                                                    </div>
                                                </div>
                                                <div class="grid-6 cell">
                                                    <div class="meta-articles__social clearfix">
                                                        <div class="social-content">
                                                            <ul class="unstyled">
                                                                <li>
                                                                    <span>Share this</span>
                                                                </li>
                                                                <li class="facebook">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;t=Hope you will not stop coming to my races, Omanyala tells Uhuru" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;t=Hope you will not stop coming to my races, Omanyala tells Uhuru" title="Facebook">
                                                                        <i class="fa fa-facebook"></i>
                                                                        <span class="hide">Facebook</span>
                                                                    </a>
                                                                </li>
                                                                <li class="twitter">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://twitter.com/intent/tweet?url=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;text=Hope you will not stop coming to my races, Omanyala tells Uhuru&via=Nairobi_News" title="Twitter">
                                                                        <i class="fa fa-twitter"></i>
                                                                        <span class="hide">Twitter</span>
                                                                    </a>
                                                                </li>

                                                                <li class="linkedin">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&title=Hope you will not stop coming to my races, Omanyala tells Uhuru&summary=Hope you will not stop coming to my races, Omanyala tells Uhuru&source=NairobiNews" title="LinkedIn">
                                                                        <i class="fa fa-linkedin"></i>
                                                                        <span class="hide">LinkedIn</span>
                                                                    </a>
                                                                </li>
                                                                <li class="email">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="mailto:?subject=Hope you will not stop coming to my races, Omanyala tells Uhuru&body=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/" title="Email" target="_blank">
                                                                        <i class="fa fa-envelope-o"></i>
                                                                        <span class="hide">Email</span>
                                                                    </a>
                                                                </li>
                                                                <li class="whatsapp">
                                                                    <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/" title="WhatsApp">
                                                                        <i class="fa fa-whatsapp"></i>
                                                                        <span class="hide">WhatsApp</span>
                                                                    </a>
                                                                </li>
                                                                
                                                                
                                                            </ul>
                                                        </div>
                                                    </div>
                                                </div>
                                            </div>
                                        </div>
                                    </div>
                                    <div class="article-content__banner">
                                        <div class="banner-container">
                                            <div class="banner-image">
                                               <img width="1320" height="742" src="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3.jpg" class="attachment-single-image size-single-image wp-post-image" alt="" />                                                                                              <!-- <img width="auto" height="auto" src="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3.jpg" loading="lazy" class="attachment-single-image size-single-image wp-post-image loaded" alt="Hope you will not stop coming to my races, Omanyala tells Uhuru" data-src="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3.jpg" title="Hope you will not stop coming to my races, Omanyala tells Uhuru" pinger-seen="true" data-was-processed="true" data-dw-processed-inimage="true" data-dw-target-viewable="true"> -->
                                            </div>
                                            <div class="banner-caption">
                                                <!--<span class="render-text"> Ferdinand Omanyala reacts after winning the men's 100m final during the national trials for the World Championships and the Commonwealth Games at the Kasarani stadium in Nairobi on June 25, 2022. PHOTO | AFP&nbsp;</span>-->
                                                <span class="render-text">Ferdinand Omanyala reacts after winning the men's 100m final during the national trials for the World Championships and the Commonwealth Games at the Kasarani stadium in Nairobi on June 25, 2022. PHOTO | AFP</span>                                            </div>
                                        </div>
                                    </div>
                                    <div class="article-content__content clearfix mt-40">
                                        
                                        <div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">
                                           <script>
											googletag.cmd.push(function() {
											googletag.defineSlot('/1010816/NN-ARTICLE-4', [300, 250], 'div-gpt-ad-1553666013837-0').addService(googletag.pubads());
											googletag.enableServices(); });
											</script>
											<div id='div-gpt-ad-1553666013837-0' style='height:250px; width:300px;'>
											<script>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553666013837-0'); });
											</script>
											</div>
                                            <br />
                                            
                                           
                                            
                                            
                                        </div>

                                        <p>Africa&#8217;s fastest man Ferdinand Omanyala has thanked retired President Uhuru Kenyatta for his service even in the sporting arena.</p>
<p>In a post shared across his social media platforms, Omanyala attached photos hugging the President captioning, &#8220;Happy retirement&#8230;hope u will not stop coming to watch my races. Thank you for your service.&#8221;</p>
<p>President Kenyatta had formed a habit of watching Omanyala&#8217;s races. In a video gone viral, President Kenyatta hugged Omanyala tightly after winning the men&#8217;s 100m race in Kip Keino Classic at Kasarani Stadium.</p><div class='mobile-ad-'>
				<!--  /1010816/NN-Arcticle-728x90 -->
				<div id='div-gpt-ad-1642148151895-0'>
				<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1642148151895-0'); });
				</script>
				</div>
			</div>
<p>The budding athlete ran his fastest time ever, clocking 9.77 seconds to finish second at the international meet in the 100 metres race behind American Trayvon Bromell.</p>
<p><span data-preserver-spaces="true">Also read:</span> <a href="https://nairobinews.nation.africa/turkish-investor-who-was-deported-by-uhurus-government-spotted-at-state-house/">Turkish ‘investor’ who was deported by Uhuru’s government spotted at State House</a></p>
<p>Whether virtually or physically, President Kenyatta was arguably one of Omanyala&#8217;s greatest cheerleaders.</p><div class='mobile-ad-'>
				<!-- /1010816/NN-Arcticle-728x90-2 -->
				<div id='div-gpt-ad-1642151579726-0'>
				<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1642151579726-0'); });
				</script>
				</div>

			</div>
<p>Having won Kenya its first gold in the Commonwealth Games in Birmingham, President Kenyatta said, &#8220;It was super exciting to watch Ferdinand win the 100m dash in style and earn our country her first gold medal in Birmingham.</p>
<p>His win is a groundbreaking achievement not just for Ferdinand but for the whole of Kenya&#8217;s athletics because he has excelled in a domain that&#8217;s not traditionally ours.&#8221;</p>
<p>Additionally, when Omanyala won Kenya medals in his international races, President Kenyatta was among the first to congratulate him.</p>
<p>Also read: <a href="https://nairobinews.nation.africa/intriguing-facts-about-president-rutos-mom-and-her-influence-in-his-life/">Intriguing facts about President Ruto’s mom and her influence in his life</a></p>
<p>It was a joyous moment for the country when Omanyala defeated South Africa&#8217;s champion Akani Simbine with State House tweeting, &#8220;President Uhuru Kenyatta has congratulated emerging Kenyan sprinter Ferdinand Omanyala following the athlete&#8217;s pulsating win of the 100m race at the ASA Athletics Grandprix 4 in South Africa.&#8221;</p>
<p>Omanyala is expected to jet back into the country on Thursday marking the end of this year&#8217;s season races.</p>
<p>The fast-paced athlete&#8217;s wife Laventa Amutavi while congratulating him for participating said, &#8220;A solid effort it was. You have gone through many championships and it has been a remarkable season. First global medals of your career and superb racing.</p>
<p>The fact that you are still pushing forward is amazing. What a year it has been. Finish strong Golden boy. Glory to God for the winnings, the challenges and breakthroughs.&#8221;</p>
<p>Also read:</p>
<p><a href="https://nairobinews.nation.africa/gone-too-soon-kenyan-actress-dies-during-treatment-after-road-accident/">Gone too soon! Kenyan actress dies during treatment after road accident</a></p>
<p><span data-preserver-spaces="true"><a href="https://nairobinews.nation.africa/no-more-arbitrary-blacklisting-how-ruto-has-rescued-loan-defaulters/">No more arbitrary blacklisting: How Ruto has rescued loan defaulters</a></span></p>
<p><a href="https://nairobinews.nation.africa/miguna-miguna-red-alerts-hindering-my-travel-to-kenya-to-be-lifted-today/">Miguna Miguna: Red alerts hindering my travel to Kenya to be lifted today</a></p>
<p><a href="https://nairobinews.nation.africa/woman-in-jkia-viral-tiktok-video-attacking-agent-speaks-of-saudi-arabia-torture/">Woman in JKIA viral Tiktok video attacking agent speaks of Saudi Arabia torture</a></p>
<p><a href="https://nairobinews.nation.africa/president-rutos-13-key-directives-on-first-day-of-power/">President Ruto’s 13 key directives on first day of power</a></p>
<p>&nbsp;</p>
                                                                            </div>
                                    
                                                                          

                                    
    
    
                                    <div class="article-content__tags">

                                        <div class="list-tags">

                                            <ul  class="unstyled"><li><a href="https://nairobinews.nation.africa/tag/africas-fastest-man/" rel="tag">Africa's fastest man</a></li><li><a href="https://nairobinews.nation.africa/tag/ferdinand-omanyala/" rel="tag">Ferdinand Omanyala</a></li><li><a href="https://nairobinews.nation.africa/tag/kasarani-stadium/" rel="tag">Kasarani Stadium</a></li><li><a href="https://nairobinews.nation.africa/tag/kip-keino-classic/" rel="tag">Kip Keino Classic</a></li><li><a href="https://nairobinews.nation.africa/tag/president-uhuru-kenyatta/" rel="tag">President Uhuru Kenyatta</a></li></ul>
                                        </div>
                                        <div class="join-wc clearfix">
                                            <div class="row">
                                                <div class="grid-8 cell">
                                                    <div class="join-text">
                                                        <p>Nairobi News is now available on Telegram. For handpicked stories every day, subscribe to our channel today</p>
                                                    </div>
                                                </div>
                                                <div class="grid-4 cell">
                                                    <div class="join-link whats-appLink">
                                                        <a href="https://telegram.me/NairobiNews" target="_blank">
                                                            <i class="fa fa-commenting-o"></i>
                                                            <span>Telegram channel</span>
                                                        </a>
                                                    </div>
                                                </div>
                                            </div>
                                        </div>
                                    </div>
                                                                        <div id="stick-article-nav" class="article-content___nav">
                                        <div class="row">
                                            <div class="grid-4 cell">
                                                                                            <div class="content-nav__item prev-item">
                                                    <a href="https://nairobinews.nation.africa/gone-too-soon-kenyan-actress-dies-during-treatment-after-road-accident/" title="Gone too soon! Kenyan actress dies during treatment after road accident">
                                                        <span class="hide-mobile">
                                                            Gone too soon! Kenyan actress dies during treatment after...                                                        </span>
                                                    </a>
                                                </div>
                                                                                        </div>
                                            <div class="grid-4 cell">
                                                <div class="meta-articles__social clearfix">
                                                    <div class="social-content">
                                                        <ul class="unstyled">
                                                            <li class="facebook">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;t=Hope you will not stop coming to my races, Omanyala tells Uhuru" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;t=Hope you will not stop coming to my races, Omanyala tells Uhuru" title="Facebook">
                                                                    <i class="fa fa-facebook"></i>
                                                                    <span class="hide">Facebook</span>
                                                                </a>
                                                            </li>
                                                            <li class="twitter">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="http://twitter.com/intent/tweet?url=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&amp;text=Hope you will not stop coming to my races, Omanyala tells Uhuru&via=Nairobi_News" title="Twitter">
                                                                    <i class="fa fa-twitter"></i>
                                                                    <span class="hide">Twitter</span>
                                                                </a>
                                                            </li>

                                                            <li class="linkedin">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/&title=Hope you will not stop coming to my races, Omanyala tells Uhuru&summary=Hope you will not stop coming to my races, Omanyala tells Uhuru&source=NairobiNews" title="LinkedIn">
                                                                    <i class="fa fa-linkedin"></i>
                                                                    <span class="hide">LinkedIn</span>
                                                                </a>
                                                            </li>
                                                            <li class="email">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="mailto:?subject=Hope you will not stop coming to my races, Omanyala tells Uhuru&body=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/" title="Email" target="_blank">
                                                                    <i class="fa fa-envelope-o"></i>
                                                                    <span class="hide">Email</span>
                                                                </a>
                                                            </li>
                                                            <li class="whatsapp">
                                                                <a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/" title="WhatsApp">
                                                                    <i class="fa fa-whatsapp"></i>
                                                                    <span class="hide">WhatsApp</span>
                                                                </a>
                                                            </li>
                                                        </ul>
                                                    </div>
                                                </div>
                                            </div>
                                            <div class="grid-4 cell">
                                                                                        </div>
                                        </div>
                                    </div>
                                </div>
                                <div class="articles-content__author mt-40">
                                    <!-- start Chatbeat script-->
                                    <script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
                                    <script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/";
                                        _sf_async_config.title = "Hope you will not stop coming to my races, Omanyala tells Uhuru";
                                        _sf_async_config.sections = "Sports,What's Hot,";
                                        _sf_async_config.authors = "Wangu Kanuri";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>
                                    <!-- end Chatbeat script-->
                                    <!-- start content insights -->
                                    <script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "201428",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "Hope you will not stop coming to my races, Omanyala tells Uhuru",
                                            pubdate: "2022-09-14",
											authors: "Wangu Kanuri",								
											sections: "Sports,What's Hot,",
                                            tags: "Africa's fastest man, Ferdinand Omanyala, Kasarani Stadium, Kip Keino Classic, President Uhuru Kenyatta, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>
                                    <!-- End content insights --> 
                                    <br />
                                                                    </div>
                                                                
                                
                            </div>
                        </div>
                        
                        <div class="grid-4 cell">
                            <div class="ad-container">
                                <div id="custom_html-27" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-2', [300, 250], 'div-gpt-ad-1553665892910-0').addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665892910-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665892910-0'); });
</script>
</div></div></div>                                                                 
                                                            </div>
                            <div id="mustr-pane" class="vidoes-pane mt-20">
                                <div class="pane-grid pane-container clearfix">
                                    <div class="pane-title posRelative mb-20">
                                        <div class="pane-title__content">
                                            <div class="pane-title__heading">
                                                <h2>
                                                    <a href="https://nairobinews.nation.africa/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
                                                </h2>
                                            </div>
                                        </div>
                                    </div>
                                                                                                                <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/gone-too-soon-kenyan-actress-dies-during-treatment-after-road-accident/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/09/WhatsApp-Image-2022-09-14-at-9.25.37-AM-180x180.jpeg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Gone too soon! Kenyan actress dies during treatment after...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/i-feel-proud-chebukati-thanks-president-ruto-for-recognising-iebc/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/08/Wafula-Chebukati-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>&#8216;I feel proud&#8217;: Chebukati thanks President Ruto...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/turkish-investor-who-was-deported-by-uhurus-government-spotted-at-state-house/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/09/Turkish-investor-cover-180x180.png)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Turkish ‘investor’ who was deported by Uhuru’s...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/cop-misses-work-guarding-high-court-judges-home-found-at-lodging-sherehe-chronicles/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/08/DNCrimescene-1-180x180.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Cop misses work guarding High Court Judge&#8217;s home,...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/miguna-miguna-red-alerts-hindering-my-travel-to-kenya-to-be-lifted-today/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2022/05/Miguna-Miguna-1-180x180.gif)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Miguna Miguna: Red alerts hindering my travel to Kenya to...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://nairobinews.nation.africa/no-more-arbitrary-blacklisting-how-ruto-has-rescued-loan-defaulters/">
                                                <div class="pane-box__img posRelative">
                                                                                                        <div class="img-boxbg wp-post-image" data-bg="url(https://nnmedia.nation.africa/uploads/2016/11/M-Pesa-Money.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>No more arbitrary blacklisting: How Ruto has rescued loan...</h3>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">September 14th, 2022</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                    </div>
                            </div>
                            <div class="ad-container">
                                <div id="custom_html-28" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-3', [300, 250], 'div-gpt-ad-1553665956712-0').addService(googletag.pubads());
googletag.enableServices(); });
</script>
<div id='div-gpt-ad-1553665956712-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665956712-0'); });
</script>
</div></div></div>                            </div>                         
                            
                            <div id="buzz-pane" class="buzz-pane">
                                <div class="pane-grid pane-container clearfix">
                                    <div class="pane-title posRelative mb-20">
                                        <div class="pane-title__content">
                                            <div class="pane-title__heading">
                                                <h2>
                                                    <a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
                                                </h2>
                                            </div>
                                        </div>
                                    </div>
                                                                          <div class="pane-box">
                                        <a href="https://www.kenyabuzz.com/movies/movie/where-the-crawdads-sing" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1662037415.jpg)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>Where the Crawdads Sing</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p> </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>
                                                                          <div class="pane-box">
                                        <a href="https://www.kenyabuzz.com/movies/movie/nope" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1660814879.jpg)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>Nope</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p> </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>
                                                                          <div class="pane-box">
                                        <a href="https://www.kenyabuzz.com/movies/movie/beast" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public/)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>Beast</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p> </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>
                                                                          <div class="pane-box">
                                        <a href="https://www.kenyabuzz.com/movies/movie/doctor-strange-in-the-multiverse-of-madness" target="_blank">
                                            <div class="pane-box__img posRelative">
                                                <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1651137254.jpg)"></div>
                                            </div>
                                            <div class="pane-box__content">
                                                <div class="content-title">
                                                    <h3>Doctor Strange in the Multiverse of Madness</h3>
                                                </div>
                                                <div class="content-capt">
                                                    <p> </p>
                                                </div>
                                                <div class="content-meta">
                                                    <span class="render-text">BUY TICKET</span>
                                                </div>
                                            </div>
                                        </a>
                                    </div>
                                                                        
                                    

                                                                            <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/events/event/irregardless-1" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1661851652.jpeg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Irregardless 2</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>After what has been a tense month, we are proud to announce... </p>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/events/event/the-heng-back-to-the-90s" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1662800489.jpeg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>The Heng: Back to the 90s</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>A musical concert that aims to bring back the nostalgia... </p>
                                                    </div>
                                                    <div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>
                                                </div>
                                            </a>
                                        </div>
                                                                        
                                    
                                                                            <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/lifestyle/the-heng-kenyas-leading-nostalgic-concert" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/lifestyle/wp-content/uploads/2022/09/Art-In-Motion-The-Heng-photo-by-Teddy-Mitchener-768x512.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>The Heng: Kenya's Leading Nostalgic Concert</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>The Heng: Kenya's Leading Nostalgic Concert </p>
                                                    </div>
                                                    <!--<div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>-->
                                                </div>
                                            </a>
                                        </div>
                                                                            <div class="pane-box">
                                            <a href="https://www.kenyabuzz.com/lifestyle/dance-centre-kenyas-new-term-dates" target="_blank">
                                                <div class="pane-box__img posRelative">
                                                    <div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/lifestyle/wp-content/uploads/2022/08/ballet.jpg)"></div>
                                                </div>
                                                <div class="pane-box__content">
                                                    <div class="content-title">
                                                        <h3>Dance Centre Kenya’s New Term Dates</h3>
                                                    </div>
                                                    <div class="content-capt">
                                                        <p>Dance Centre Kenya’s New Term Dates </p>
                                                    </div>
                                                    <!--<div class="content-meta">
                                                        <span class="render-text">BUY TICKET</span>
                                                    </div>-->
                                                </div>
                                            </a>
                                        </div>
                                                                       
                                </div>
                            </div>
                            
                            <div id="taboola-ads" class="taboola-ad-below-article content-sticky">
                                    <!-- start revenue script-->
                                    <div id="taboola-below-article-thumbnails"></div>
                                    <script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>
                                    <!-- end revenue script-->
                                </div>
                                
                        </div>
                     
                        
                    </div>
                </div>
            </div>
            <div class="smart_scroll_container" id='post-201400'></div>
        </section>
    </main>


<footer id="main-footer" class="mt-40" role="section">
    <div class="top-footer padt40 padb40 clearfix">
        <div class="content">
            <div class="row">
                <div class="row">
                    <div class="grid-4 cell">
                        <div class="top-footer__about">
                            <div class="about-logo__img">
                                <img src="https://nnmedia.nation.africa/assets/images/logo-footer.png" alt="Nairobi News Logo" />
                            </div>
                                                        
                            								                                    <!-- /1010816/NN-Profit-Button body-->
                                       <div id='div-gpt-ad-1646634584003-0'>
                                            <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1646634584003-0'); });</script>
                                        </div>
                                    
                                                            
                                                        <!-- /1010816/NN-Home-300x250-1 -->
                           
                        </div>
                    </div>
                    <div class="grid-4 cell">
                        <div class="pane-grid pane-container clearfix">
                            <div class="pane-title posRelative mb-20">
                                <div class="pane-title__content">
                                    <div class="pane-title__heading">
                                        <h2>
                                           Most Popular
                                        </h2>
                                    </div>
                                </div>
                            </div>
                                                                                    <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/ronald-karauri-sworn-in-and-kot-react-to-his-wifes-congratulatory-message/"><img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/09/Ronald-Karauri-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/ronald-karauri-sworn-in-and-kot-react-to-his-wifes-congratulatory-message/">Ronald Karauri sworn in and KOT react to his wife&#8217;s congratulatory message</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 10th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                                                        <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/twitter-investigating-cnns-larry-madowo-over-queen-elizabeth-story/"><img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2020/03/Larry-Madowo-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Former NTV presenter Larry Madowo. PHOTO | COURTESY" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/twitter-investigating-cnns-larry-madowo-over-queen-elizabeth-story/">Twitter investigating CNN&#8217;s Larry Madowo over Queen Elizabeth story</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 10th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                                                        <div class="pane-box">
                               <div class="pane-box__img">
                                   <a href="https://nairobinews.nation.africa/raila-odinga-spots-swollen-lip-bruised-nose-in-first-public-appearance-since-supreme-court-ruling/"><img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/09/Raila-Odinga-and-Uhuru-Kenyatta-130x73.png" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Uhur Kenyatta gives Raila Odinga a courtesy call at his home in Karen." loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/raila-odinga-spots-swollen-lip-bruised-nose-in-first-public-appearance-since-supreme-court-ruling/">Raila Odinga spots swollen lip, bruised nose in first public appearance since Supreme Court ruling</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 7th, 2022</span>
                                        </div>
                                    </div>
                                
                            </div>
                            
                        </div>
                    </div>
                    <div class="grid-4 cell">
                        <div class="pane-grid pane-container clearfix">
                            <div class="pane-title posRelative mb-20">
                                <div class="pane-title__content">
                                    <div class="pane-title__heading">
                                        <h2>
                                           Don't Miss
                                        </h2>
                                    </div>
                                </div>
                            </div>
                                                                                    <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/07/Omanyala-3-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/hope-you-will-not-stop-coming-to-my-races-omanyala-tells-uhuru/">Hope you will not stop coming to my races, Omanyala tells Uhuru</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 14th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                                                        <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/gone-too-soon-kenyan-actress-dies-during-treatment-after-road-accident/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/09/WhatsApp-Image-2022-09-14-at-9.25.37-AM-130x73.jpeg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="The late Kenyan actress Faith Nduku" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/gone-too-soon-kenyan-actress-dies-during-treatment-after-road-accident/">Gone too soon! Kenyan actress dies during treatment after road accident</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 14th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                                                        <div class="pane-box">
                                
                                    <div class="pane-box__img">
                                        <a href="https://nairobinews.nation.africa/i-feel-proud-chebukati-thanks-president-ruto-for-recognising-iebc/"> <img width="130" height="73" src="https://nnmedia.nation.africa/uploads/2022/08/Wafula-Chebukati-130x73.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="" loading="lazy" /></a>
                                    </div>
                                    <div class="pane-box__content">
                                        <div class="content-title">
                                            <h3><a href="https://nairobinews.nation.africa/i-feel-proud-chebukati-thanks-president-ruto-for-recognising-iebc/">&#8216;I feel proud&#8217;: Chebukati thanks President Ruto for recognising IEBC</a></h3>
                                        </div>
                                        <div class="content-meta">
                                            <span class="render-text">September 14th, 2022</span>
                                        </div>
                                    </div>
                               
                            </div>
                            
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="bottom-footer text-center padt20 padb20">
            <span class="render-text">
                Copyright &copy; 2022 Nation Media Group. All rights reserved.
            </span>
    </div>

</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<script src="https://nnmedia.nation.africa/assets/js/plugins.js"></script>
<script src="https://nnmedia.nation.africa/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>	
    <script type="text/javascript" async>
        window._taboola = window._taboola || [];
        _taboola.push({article:'auto'});
        !function (e, f, u, i) {
            if (!document.getElementById(i)){
                e.async = 1;
                e.src = u;
                e.id = i;
                f.parentNode.insertBefore(e, f);
            }
        }(document.createElement('script'),
            document.getElementsByTagName('script')[0],
            '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
            'tb_loader_script');
    </script>
<script type="text/javascript" async>
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript" async>
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#!'+id;
          window.history.pushState({path:newurl},'',newurl);
		  //alert(id);
      }
    }
</script>

<script type='text/javascript'>
    (function() {
        /** CONFIGURATION START **/
        var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
        _sf_async_config.uid = 63208; //CHANGE THIS TO YOUR ACCOUNT ID
        _sf_async_config.domain = 'nairobinews.nation.africa'; //CHANGE THIS TO YOUR SITE ID
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = true;
        _sf_async_config.sections = ''; //SET PAGE SECTION(S)
        _sf_async_config.authors = ''; //SET PAGE AUTHOR(S)
        /** CONFIGURATION END **/
        function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat.js';
            n.parentNode.insertBefore(e, n);
        }
        loadChartbeat();
     })();
    </script>
<!-- /1010816/NN-Out-of-Page -->
<div id='div-gpt-ad-1656397419267-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1656397419267-0'); });
  </script>
</div>
<!-- /1010816/NN-1x1 -->
<div id="gpt-passback">
  <script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-1x1', [1, 1], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
<div id='div-gpt-ad-1632916589183-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1632916589183-0'); });
  </script>
</div>
<!-- Google Tag Manager (noscript) -->
</div>
<script>window.tentacles = {apiToken: 'w2vn6fbas3t2q3zf5vtz9vx6md2exan5'};</script>
<script async src="https://tentacles.smartocto.com/ten/tentacle.js"></script>
</body>
</html>